Help Desk and PC Inventory Software by Gritware   Gritware Support Forums
Gritware Support Forums
Register Latest Topics
 
 
 


Reply
  Author   Comment  
dtinsley

Member
Registered:
Posts: 7
Reply with quote  #1 
Hello,

I am performing a new install of WebTracks  2014 9.2.1 and the Web Tracks Setup Wizard is prompting to upgrade the database from 9.10 to 9.20.  It then fails with error "Conversion from string "" to type 'Boolean' is not valid.".  This is a fairly vague error message and I could use some assistance on how to proceed.  Thanks!

Attached Images
Click image for larger version - Name: WebTracks_error.JPG, Views: 11, Size: 58.81 KB 

thoese

Moderator
Registered:
Posts: 480
Reply with quote  #2 
Hi,

I'm sorry you're experiencing this issue.  I have a good guess as to what the issue is...

My guess is that you installed 9.2.1 on a different server.  If this is the case copy the db.config file from the previous installation located in C:\Program Files (x86)\Gritware\Web Tracks\Webroot folder to the same folder on your new server.  Then try the update process again.  This is a bug when switching servers and upgrading the database in the same step.

Sorry for any inconvenience.

Thanks,

__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
dtinsley

Member
Registered:
Posts: 7
Reply with quote  #3 
Hey Todd,

Thank you for the reply.  I did notice the "db.config" file looked like it was missing something.  Unfortunately the old server crashed so there is no other backup of the "db.config" file.  Any other resolutions you know of?  Appreciate it!
thoese

Moderator
Registered:
Posts: 480
Reply with quote  #4 
Hi,

Try manually creating the db.config file (using notepad.exe) -- make sure that it's not saved with the .txt extension.

Here would be the contents of the file.  You would need to adjust these to match your SQL server settings...


<connectionStrings>
<addname="WebTracks"connectionString="Provider=sqloledb;Data Source=YourSqlServer;Initial Catalog=YourWebTracksDatabaseName;User Id=YourWebTracksSQLUserID;password=YourWebTracksSQLPassword" />

</connectionStrings>

Thanks,

__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
dtinsley

Member
Registered:
Posts: 7
Reply with quote  #5 
Good morning,

Thank you for the db file contents.  I'm still working through this.  Seems it doesn't like the "=" after "addname".  Please see attached screenshot.  Is that the correct syntax or am I missing something? db config error.JPG 

dtinsley

Member
Registered:
Posts: 7
Reply with quote  #6 
At this point I was able to modify the db.config file to a point where it prompts to update the database when launching WebTracks.  Unfortunately I am now back to the original error message "Conversion from string "" to type 'Boolean' is not valid.".  Any other ideas??

Thanks in advance!
thoese

Moderator
Registered:
Posts: 480
Reply with quote  #7 
Hi I'm sorry you're still getting this error.  I thought that should fix things.  If you are getting the prompt to upgrade the database you must have the db.config file syntax correct since it's finding your database.

I have a couple options for you to try.

One would be to restore a copy of the database prior to any upgrade attempt and then try the upgrade procedure again.

Another would be to uninstall Web Tracks and then install the prior version (version 9.1.1).  This should connect to the database without upgrading.  After doing this install version 9.2.1 and run the upgrade procedure again.

If either of these don't work let's plan on doing a remote control session and hopefully I can help you get this going.

Sorry for any inconvenience,

Best Regards,


__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
dtinsley

Member
Registered:
Posts: 7
Reply with quote  #8 
Hey Todd,

Installing the older version of WebTracks had a different error all together.  If possible can we schedule a remote session for Monday the 31st?  I left you a voicemail as well.  Please advise and thanks!
dtinsley

Member
Registered:
Posts: 7
Reply with quote  #9 
Hey Todd,

Was able to get the install to complete by creating a new database.  I have a question about the license key though.  Please let me know when you have a moment for me to contact you.  Just need to know if the 9.1.1 license can be upgraded to work with 9.2.1.

Thank you!
dtinsley

Member
Registered:
Posts: 7
Reply with quote  #10 
Todd,

Got the 9.1.1 version of WebTracks to work properly.  Thanks.
thoese

Moderator
Registered:
Posts: 480
Reply with quote  #11 
I'm happy to hear you got this going.  If you wanted to attempt the upgrade to 9.2.1 let me know and I could go over it with you.

Have a great day!

__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.