Help Desk and PC Inventory Software by Gritware   Gritware Support Forums
Gritware Support Forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Canadianmade

Member
Registered:
Posts: 69
Reply with quote  #1 
When creating a new service desk ticket I got the following error when trying to save.

STATUS: Error Saving Record. Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Is this a error on the webserver or the SQL server?
thoese

Moderator
Registered:
Posts: 491
Reply with quote  #2 
I have not seen this error message before.  I will do some research on it to see if I can find out what's causing the problem.

Do you get this message in other areas of the program or just the Help Desk?  Have you always been getting this message or did it start after making some changes? 

Feel free to call me and I can try to help.

Thank you,

__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
Canadianmade

Member
Registered:
Posts: 69
Reply with quote  #3 
Seems to just be the service desk. I can add a peripheral no problem. I recently imported tickets from another helpdesk system but I have created service desk tickets since then. I don't think I have made any changes since that.
I try to recycle the app pool and restart the SQL instance first before contacting you.
Canadianmade

Member
Registered:
Posts: 69
Reply with quote  #4 
I was copying and pasting information from a HTML email into the description portion. This seems to cause the error even though it looks like it just converts it to TXT.
I will put in a suggestion to be able to have HTML formatting in tickets and other areas, this would also work if we want to link to something on our network drives instead of adding it to the SQL database.
thoese

Moderator
Registered:
Posts: 491
Reply with quote  #5 
You should be able to copy html into the description field.  Yes it will convert it to plain text but it should not cause an error.

Do a quick test and try to create a ticket with the following html...

<b>My New Ticket</b>


Does it allow this?

If not edit the web.config file in C:\Program Files (x86)\Gritware\Web Tracks\WebRoot

Find the following...

<pages validateRequest="true">

change it to...

<pages validateRequest="true" requestValidationMode="2.0">

Let me know if this helps.  Thanks!


__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
Canadianmade

Member
Registered:
Posts: 69
Reply with quote  #6 
That worked fine, I was able to create the ticket just fine. The email has a image in it that was part of the copy/paste, could that cause it?

*EDIT* - I copy/pasted the email without the image and the ticket created fine. Although when pasting there was no indication of code or the image in the description box it still seems to throw the error.

thoese

Moderator
Registered:
Posts: 491
Reply with quote  #7 
Ok,

Could you forward me the original email you tried to copy?  I'm curious as to whether or not I can reproduce your original issue.

__________________
Todd @ Gritware
Other resources
Gritware.com
Knowledge Base
Web Tracks Help
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.